手机端
爱约信 广告招租
当前位置:爱约股 > 通达信 > 通达信霸王别姬主图指标公式

通达信霸王别姬主图指标公式

RSV:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=((3 * K) - (2 * D));
RSV12:=(((CLOSE - LLV(LOW,34)) / (HHV(HIGH,34) - LLV(LOW,34))) * 100);
K12:=SMA(RSV12,3,1);
D12:=SMA(K12,3,1);
J12:=((3 * K12) - (2 * D12));
RSV24:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
K24:=SMA(RSV24,3,1);
D24:=SMA(K24,3,1);
J24:=((3 * K24) - (2 * D24));
生当为人杰:=IF(CROSS(J,J24),LOW,REF(LOW,BARSLAST(CROSS(J,J24)))),LINETHICK2,COLORFFFFFF;
死亦为鬼雄:=IF(CROSS(J24,J),HIGH,REF(HIGH,BARSLAST(CROSS(J24,J)))),LINETHICK2,COLORFFEEFF;
剑在手:EMA(CLOSE,3),COLORFFFF77;
悲欢共:EMA(CLOSE,5),COLORFF00EE;
生死同:EMA(悲欢共,5),COLORFFFFFF;
VARF1:=(COUNT(CROSS(剑在手,生死同),2) = 1);
VARF2:=(COUNT(CROSS(悲欢共,生死同),2) = 1);
ZAI:=FILTER((VARF1 AND VARF2),2);
DRAWTEXT(ZAI,生死同,' →◆●¤汉兵已掠地'),COLORFFFFFF;
VV2:=REF(CLOSE,1);
VV3:=((SMA((CLOSE - VV2),6,1) / SMA(ABS((CLOSE - VV2)),6,1)) * 100);
DRAWICON(((REF(VV3,1) > 81) AND (VV3 < 80)),HIGH,2);
DRAWTEXT(((REF(VV3,1) > 81) AND (VV3 < 80)),HIGH,' →◆●四面楚歌声↓'),COLORFFFFFF;
VAR1:=((((HIGH + LOW) + OPEN) + (2 * CLOSE)) / 5);
VAR2:=REF(VAR1,1);
VAR3:=((SMA(MAX((VAR1 - VAR2),0),10,1) / SMA(ABS((VAR1 - VAR2)),10,1)) * 100);
HY3:=IF(((((COUNT((VAR3 < 20),5) >= 1) AND (COUNT((VAR1 = LLV(VAR1,10)),10) >= 1)) AND (CLOSE >= (OPEN * 1.038))) AND (VOL > (MA(VOL,5) * 1.2))),1,0);
DRAWTEXT(HY3,LOW,' →◆●▲四方云动!!'),COLORFFDDDD;
S:=(MA(VOL,5) / MA(VOL,60));
BIAS:=MA(S,5);
F:=(((CLOSE - MA(CLOSE,5)) / MA(CLOSE,5)) * 100);
LC:=MA(S,121);
RSV1:=(((CLOSE - LLV(LOW,45)) / (HHV(HIGH,45) - LLV(LOW,45))) * 100);
K1:=SMA(RSV1,15,1);
D1:=SMA(K1,15,1);
J1:=((3 * K1) - (2 * D1));
RSI:=REF(CLOSE,1);
S1:=((SMA(MAX((CLOSE - RSI),0),6,1) / SMA(ABS((CLOSE - RSI)),6,1)) * 100);
DRAWTEXT(CROSS(84,S1),H*0.99,' ←←◆●豪情天纵!!◆●'),COLORFFFFEE;
VAR4:=IF(((((J < 11) AND (F > (0 - 11))) AND CROSS(S,LC)) AND ((S - LC) > 0.01)),2,0);
DRAWTEXT((VAR4 = 2),LOW,' →◆● 四方云动!! ◆● '),COLORFF0000;
VAR1Q:=IF(((YEAR = 2999) AND (MONTH > 12)),0,1);
垓下:(MA(((AMOUNT / VOL) / 100),10.2) * VAR1Q),POINTDOT,LINETHICK2,COLORFFFFFF;
灞上:(MA(((AMOUNT / VOL) / 100),41) * VAR1Q),LINETHICK2,COLORFFFF33;
江东:(MA(((AMOUNT / VOL) / 100),118) * VAR1Q),LINETHICK2,COLORFF00FF;
VAR2Q:=(EMA((EMA(((AMOUNT / VOL) / 100),5) * 1.062),5) * 1.062);
VAR3Q:=(EMA((EMA(((AMOUNT / VOL) / 100),3) * 0.538),3) * 0.538);
DRAWTEXT((CLOSE > VAR2Q),CLOSE,'←←←暂别离'),COLORFF0000;
DRAWTEXT((CLOSE < VAR3Q),CLOSE,'←←←且偷欢'),COLORFF00EE;
JJ:=(((CLOSE > 垓下) AND ABS(((垓下 - 江东) <= 1))) AND CROSS(垓下,灞上));
DRAWTEXT(JJ,LOW,'←←←兵变举事'),COLORFFFF00;
H1A:=((((HIGH + LOW) + CLOSE) + OPEN) / 4);
VAR1R:=REF(CLOSE,1);
VAR2R:=((SMA(MAX((CLOSE - VAR1R),0),6,1) / SMA(ABS((CLOSE - VAR1R)),6,1)) * 100);
DRAWTEXT(CROSS(84,VAR2R),(HIGH * 1.01),'←←←恨别离!! '),COLORFFFF33;
DRAWICON(CROSS(84,VAR2R),(HIGH * 1.03),2);
DRAWICON(CROSS(((REF(HIGH,1) + REF(LOW,1)) / 2),(MA(CLOSE,20) + (2 * STD(CLOSE,20)))),(HIGH * 1.03),2);
H1A1:=(((HIGH + LOW) + CLOSE) / 3);
VAR11:=(((((2 * CLOSE) + HIGH) + LOW) + OPEN) / 5);
VAR12:=LLV(LOW,5);
VAR13:=HHV(HIGH,4);
VAR14:=EMA((((VAR11 - VAR12) / (VAR13 - VAR12)) * 100),4);
VAR5:=EMA(((0.667 * REF(VAR14,1)) + (0.333 * VAR14)),2);
DRAWTEXT((CROSS(VAR14,VAR5) AND (VAR14 < 40)),LOW,'至今思项羽'),COLOR10FF10;
{ 爱约股_通达信股票指标公式}
VAR1E:=(((CLOSE - MA(CLOSE,30)) / MA(CLOSE,30)) * 100);
VAR2E:=((CLOSE > OPEN) AND ((OPEN - LOW) > (HIGH - CLOSE)));
VAR3E:=((REF(VAR1E,1) < (0 - 20)) AND VAR2E);
JJE:=(((REF(VAR1E,1) < (0 - 20)) AND (CLOSE > OPEN)) AND ((((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) * 1000) > 20));
VAR9E:=FILTER((VAR3E OR JJE),3);
VAR7E:=((OPEN > CLOSE) AND ((HIGH - IF((CLOSE > OPEN),CLOSE,OPEN)) > (IF((OPEN < CLOSE),OPEN,CLOSE) - LOW)));
VAR8E:=((REF(VAR1E,1) > ABS((0 - 20))) AND VAR7E);
VAR10E:=(((REF(VAR1E,1) > ABS((0 - 20))) AND (CLOSE < OPEN)) AND ((((REF(CLOSE,1) - CLOSE) / REF(CLOSE,1)) * 1000) > 20));
VARC:=FILTER((VAR8E OR VAR10E),3);
VARAE:=((REF(VAR1E,1) < (0 - 13)) AND VAR2E);
VARBE:=(((REF(VAR1E,1) < (0 - 13)) AND (CLOSE > OPEN)) AND ((((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) * 1000) > 20));
VARD:=FILTER((VARAE OR VARBE),3);
VARE:=((REF(VAR1E,1) > ABS((0 - 13))) AND VAR7E);
VARF:=(((REF(VAR1E,1) > ABS((0 - 13))) AND (CLOSE < OPEN)) AND ((((REF(CLOSE,1) - CLOSE) / REF(CLOSE,1)) * 1000) > 20));
VAR15:=FILTER((VARE OR VARF),3);
DRAWICON(((VAR9E* VAR1E) > 0),LOW,1);
DRAWICON(((VARC * VAR1E) > 0),HIGH,2);
DRAWTEXT(((VARD * VAR1E) > 0),(1.02 * REF(CLOSE,1)),'积极关注'),COLORFFFFFF;
DRAWTEXT(((VAR15 * VAR1E) > 0),(0.99 * REF(CLOSE,1)),'←←←逃离苦海'),COLOR1010FF;
VAR11E:=(((((2 * CLOSE) + HIGH) + LOW) + OPEN) / 5);
VAR12E:=LLV(LOW,5);
VAR13E:=HHV(HIGH,4);
VAR14E:=EMA((((VAR11E - VAR12E) / (VAR13E - VAR12E)) * 100),4);
VAR5R:=EMA(((0.667 * REF(VAR14E,1)) + (0.333 * VAR14E)),2);
DRAWTEXT((CROSS(VAR14,VAR5R) AND (VAR14E < 40)),LOW,'至今思项羽'),COLOR10FF10;
VAR16:=(EMA(VAR11E,13) - EMA(VAR11E,34));
VAR17:=EMA(VAR16,5);
VAR18:=(((0 - 2) * (VAR16 - VAR17)) * 3.8);
DRAWTEXT((CROSS(VAR18,MA(VAR18,3)) AND (VAR16 > VAR17)),HIGH,'情天纵!!'),COLOR10FFFF;
VAR19:=((((2 * CLOSE) + LOW) + HIGH) / 4);
VAR1R1:=EMA(CLOSE,8);
VAR2R1:=EMA(CLOSE,20);
STICKLINE((VAR1R1 > VAR2R1),VAR2R1,VAR1R1,2,1),COLORFFFF00;
VAR3S:=SMA(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),14,1);
JJS:=(HIGH - REF(HIGH,1));
VAR9S:=(REF(LOW,1) - LOW);
VAR7S:=SMA(IF(((JJS > 0) AND (JJS > VAR9S)),JJS,0),12,1);
VAR8S:=SMA(IF(((VAR9S > 0) AND (VAR9S > JJS)),VAR9S,0),12,1);
VAR10S:=((VAR7S * 100) / VAR3S);
VARCS:=((VAR8S * 100) / VAR3S);
VARAS:=SMA(((ABS((VARCS - VAR10S)) / (VARCS + VAR10S)) * 100),12,1);
VARBS:=((VARAS + REF(VARAS,5)) / 2);
VARDS:=((SUM((HIGH - OPEN),12) / SUM((OPEN - LOW),12)) * 100);
VARES:=((SUM(MAX(0,(HIGH - REF(CLOSE,1))),12) / SUM(MAX(0,(REF(CLOSE,1) - LOW)),12)) * 100);
VARFS:=((AMOUNT / VOL) / 100);
VAR15S:=(((((3 * HIGH) + LOW) + OPEN) + (2 * CLOSE)) / 7);
VAR11S:=((SUM(AMOUNT,5) / VARFS) / 100);
VAR12S:=((SUM(AMOUNT,13) / VARFS) / 100);
VAR13S:=((SUM(AMOUNT,34) / VARFS) / 100);
VAR14S:=((SUM(AMOUNT,209) / VARFS) / 100);
VAR5S:=(((REF(VOL,1) + REF(VOL,2)) + REF(VOL,3)) + REF(VOL,4));
VAR16S:=(VAR5S / CAPITAL);
VAR17S:=(((VOL / CAPITAL) * VAR15S) + (VAR16S * REF(VARFS,1)));
CYC5:=IF((DATE < 1500501),DMA(VAR15S,(VOL / VAR11S)),0);
CYC13:=IF((DATE < 1500501),DMA(VAR15S,(VOL / VAR12S)),0);
CYC34:=IF((DATE < 1500501),DMA(VAR15S,(VOL / VAR13S)),0);
CYC无穷大:=IF((DATE < 1500501),DMA(VAR15,(VOL / CAPITAL)),0);
VAR18S:=((100 * (CLOSE - CYC5)) / CYC5);
VAR19S:=((100 * (CLOSE - CYC13)) / CYC13);
VAR1A:=((100 * (CLOSE - CYC34)) / CYC34);
VAR1B:=((100 * (CLOSE - CYC无穷大)) / CYC无穷大);
VAR1C:=MA(CLOSE,13);
VAR1D:=((100 * (VAR1C - REF(VAR1C,1))) / REF(VAR1C,1));
VAR1ES:=(CLOSE - LOW);
VAR1F:=(HIGH - LOW);
VAR20:=(CLOSE - HIGH);
VAR21:=IF((CLOSE >= 0),(((VAR1E / VAR1F) + (VAR20 / VAR1F)) * VOL),(((VAR20 / VAR1F) + (VAR1E / VAR1F)) * VOL));
VAR22:=(SUM(VAR21,10) / 10000);
VAR23:=((100 * (CYC13 - REF(CYC13,1))) / REF(CYC13,1));
VAR24:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
VAR25:=SMA(VAR24,3,1);
VAR26:=SMA(VAR25,3,1);
VAR27:=((3 * VAR25) - (2 * VAR26));
VAR28:=(((CLOSE - LLV(LOW,60)) / (HHV(HIGH,60) - LLV(LOW,60))) * 100);
VAR29:=SMA(VAR28,5,1);
VAR2A:=SMA(VAR29,10,1);
VAR2B:=CROSS(VAR2A,VAR29);
VAR2C:=((VAR2A > 80) OR (VAR29 > 80));
VAR2D:=(VAR2B AND VAR2C);
VAR2ES:=(((VAR1D > 0) AND (VAR23 > 0)) AND (VAR22 > 0));
VAR2F:=((((VAR1D < 0) OR (VAR23 < 0)) OR (VAR22 < 0)) OR (VAR19 < 0));
VAR30:=CLOSE;
VAR31:=OPEN;
VAR32:=HIGH;
VAR33:=LOW;
VAR34:=LLV(LOW,240);
VAR35:=(((100 * (CLOSE - VAR34)) / VAR34) > 15);
VAR36:=(((100 * (CLOSE - VAR34)) / VAR34) < 45);
VAR37:=((100 * (CLOSE - VAR34)) / VAR34);
VAR38:=(VAR35 AND VAR36);
VAR39:=(100 * (WINNER(CLOSE) - WINNER((0.7 * CLOSE))));
VAR3A:=((100 * (CYC5 - REF(CYC5,1))) / REF(CYC5,1));
VAR3B:=(((VAR39 > 70) AND (VAR3A > 1)) AND VAR38);
DRAWTEXT(VAR3B,LOW,'密探军营'),COLORFF0099;
VAR3C:=(((VAR19 - LLV(VAR19,60)) / (HHV(VAR19,60) - LLV(VAR19,60))) * 100);
VAR3D:=LLV(LOW,240);
VAR3ES:=((100 * (CLOSE - VAR3D)) / VAR3D);
VAR3F:=(WINNER(CLOSE) / SMA((VOL / CAPITAL),13,1));
VAR40:=((100 * VOL) / CAPITAL);
VAR41:=(100 * (WINNER(CLOSE) - REF(WINNER(CLOSE),1)));
VAR42:=(VAR41 / VAR40);
VAR43:=(1.1 * CLOSE);
VAR44:=(0.9 * CLOSE);
VAR45:=(100 * (WINNER(VAR43) - WINNER(VAR44)));
VAR46:=((100 * (CLOSE - COST(0))) / (COST(100) - COST(0)));
VAR47:=(((CLOSE - LLV(LOW,240)) / (HHV(HIGH,240) - LLV(LOW,240))) * 100);
VAR48:=(((CLOSE - LLV(LOW,480)) / (HHV(HIGH,480) - LLV(LOW,480))) * 100);
VAR49:=(WINNER(CLOSE) / (VOL / CAPITAL));
VAR4A:=(100 * (1 - WINNER(CLOSE)));
神奇趋势线:=(((((((((VAR37 < 1) AND (VAR49 < 0.3)) AND (VAR3F < 0.3)) AND (VAR42 < 0)) AND (VAR47 < 0.5)) AND (VAR48 < 0.5)) AND (VAR45 < 1.5)) AND (VAR46 < 1)) AND (VAR3C = 0));
DRAWTEXT(神奇趋势线,LOW,'至今思项羽'),COLORFFFF66;
DRAWICON(((VAR9E * VAR1) > 0),LOW,1);
DRAWICON(((VARC * VAR1) > 0),HIGH,2);
DRAWTEXT(((VARD * VAR1) > 0),(1.02 * REF(CLOSE,1)),'积极关注'),COLORFFFFFF;
DRAWTEXT(((VAR15 * VAR1) > 0),(0.99 * REF(CLOSE,1)),'←←←风声鹤唳'),COLOR1010FF;
VAR11F:=(((((2 * CLOSE) + HIGH) + LOW) + OPEN) / 5);
VAR12F:=LLV(LOW,5);
VAR13F:=HHV(HIGH,4);
VAR14F:=EMA((((VAR11F - VAR12F) / (VAR13F - VAR12F)) * 100),4);
VAR5F:=EMA(((0.667 * REF(VAR14F,1)) + (0.333 * VAR14F)),2);
DRAWTEXT((CROSS(VAR14F,VAR5F) AND (VAR14 < 40)),LOW,'至今思项羽'),COLOR10FF10;
VAR16F:=(EMA(VAR11F,13) - EMA(VAR11F,34));
VAR17F:=EMA(VAR16F,5);
VAR18F:=(((0 - 2) * (VAR16F - VAR17F)) * 3.8);
DRAWTEXT_FIX(CURRBARSCOUNT=60,0.02,0.01,0,'====【大王情切切,四面楚歌声】===='),COLORGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=60,0.4,0.01,0,'====【爱你=爱我】鼎力制作===='),COLORGREEN;

 

通达信霸王别姬主图指标公式

分享至:

相关推荐