手机端
当前位置:智股网 > 公式技巧 > 同花顺软件的“趋势操盘”指标转选股指标

同花顺软件的“趋势操盘”指标转选股指标

 网友求助:

很好用的一个指标,红色持股、黄色观望、绿色持币。求可以筛选出发出第一个红色信号时的选股公式

源码如下:

N 1 20 13
M 1 20 5

Var2:=(HIGH+LOW+CLOSE*2)/4;
Var3:=EMA(Var2,21);
Var4:=STD(Var2,21);
Var5:=((Var2-Var3)/Var4*100+200)/4;
Var6:=(EMA(Var5,5)-25)*1.56;
AK: EMA(Var6,2)*1.22;
AD1: EMA(AK,2);
AJ: 3*AK-2*AD1;
a:100;
b:0;
e:80;
a1=CLOSE>MA(CLOSE,n);
a2=CLOSE<MA(CLOSE,m);
a3=CLOSE>MA(CLOSE,m) AND CLOSE<MA(CLOSE,n);
IF(a1==1 AND AK>AD1) RETURN ("colorred");
ELSE IF (a3==1) RETURN("coloryellow");
ELSE IF (a2==1 AND AK>AD1) RETURN("coloryellow");
ELSE IF (a1==1 AND AK<AD1) RETURN("coloryellow");
ELSE RETURN("colorgreen");

 

同花顺软件的“趋势操盘”指标转选股指标

 

 

 

解答如下:

Var2:=(HIGH+LOW+CLOSE*2)/4;
Var3:=EMA(Var2,21);
Var4:=STD(Var2,21);
Var5:=((Var2-Var3)/Var4*100+200)/4;
Var6:=(EMA(Var5,5)-25)*1.56;
AK:=EMA(Var6,2)*1.22;
AD1:=EMA(AK,2);
XG:CROSS(C,MA(C,13)) AND AK>AD1;

分享至:

相关推荐